Zavřít reklamu

Pokud máte na vašem zařízení iOS 4.0.2 nebo iOS 3.2.2 na iPadu a mysleli jste si, že se brzy dočkáte nového jailbreaku, tak vás musíme zklamat. Jailbreak pro tyto iOS nebude. Toto stanovisko sdělil Dev-Team na svém blogu.

Poslední vydaný jailbreak – jailbreakme.com byl pro všechny fanoušky jailbreaku velký úspěch, který posunul hackování na další úroveň. Provést ho na svém přístroji nebylo totiž nikdy jednodušší. Stačilo jen přejet prstem a chvíli si počkat (návod na jailbreakme.com zde). Jailbreakme.com totiž využívá bezpečnostní chybu na iOS u PDF souborů.

Protože tato chyba přestavuje hrozbu nejen pro společnost Apple, ale hlavně pro uživatele, bylo jen otázkou času, kdy na tuto díru přijde záplata. Z hlediska běžných uživatelů je to však dobře, protože těm může být díky této chybě během chvíle smazán kompletní iPhone.

Hackeři si s opravou bezpečnostního problému poradili po svém. Přišli na jednoduchou opravu. Stačilo si nainstalovat v Cydii šikovnou utilitu, která se vás vždy přes stáhnutím PDF souboru zeptá, zda to opravdu chcete (článek zde). Ale co uživatelé bez jailbreaku?

Zdroj: Redakce Jablíčkář.cz

Společnost Apple nelenila. Brzy vydala iOS 4.0.2, který nepřináší nic nového kromě opravení bezpečnostní chyby. Tím bylo zamezeno použití jailbreakme.com. Objevilo se tedy několik dotazů adresovaných Dev-Teamu, zda vydají jailbreak i pro tento nový iOS. Odpověď však byla jasná, Dev-Team nebude vyvíjet jailbreak pro 4.0.2, protože by to bylo mrhání časem.

Dalo by se říci, že Dev-Team hraje se společností Apple hon na kočku a myš. Hackeři představují myši, hledající skulinu v zabezpečení přístroje, aby mohli provést jailbreak. Po jeho vydání však kočka – společnost Apple tuto díru zazdí. Proto nelze než souhlasit s tím, že jailbreak pro iOS 4.0.2 je prostě zbytečnost.

I kdyby hackeři přišli na nějakou skulinu, Apple momentálně připravuje iOS 4.1 a programátoři této společnosti by do něj mohli velmi snadno přidat další záplatu.

Ti uživatelé, kteří si svůj přístroj na verzi iOS 4.0.2 updatovali, si budou muset počkat na vydání jailbreaku pro iOS 4.1. Výjimku tvoří pouze majitelé iPhonu 3G, u nějž lze stále použít nástroj RedSn0w i pro 4.0.2. Což působí dojmem, že je to společnosti Apple u tohoto modelu jedno.

Zdroj: blog.iphone-dev.org

Diskuze k článku

    Nastesti jsem se rozhodl to jailbreaknout na 4.01, a duvod k dalsimu upgradu systemu nejak nevidim. Alespon dokad nebudou standartni spoucasti systemu telefoni fce jako ma treba IrealSMS na Cydii.

    Prosím, jak jde downgrade z 4.0.2 na 4.0.1 ?? Kámoš má ipod touch 3G 8GB a upgradoval na 4.0.2 a teď neví jak zpátky na 4.0.1. Když stáhne firmware 4.0.1 a dá ho do restore (i třeba přes DFU mod), tak mu to pořád hází nějaké errory ?? Plís help :D

    Může zkusit tento návod http://jablickar.cz/downgradujte-svuj-iphone-3g-na-ios-3-1-3/ , ale pochybuji, že to bude fungovat. S iPodem Touch bohužel nemám zkušenosti, ale pokud si neudělal SHSH zálohu, tak podle mě má smůlu.

    iPody 2. generace a výš a iPhony 3GS a výš nejdou downgradovat. Mají v sobě hardwarovou ochranu, která se nedá jednoduše překonat.

    ano mozem potvrdit tiez, mam IP 3G os 4.0.2 a jailbreak cez redsn0w. Privyberani OS sa cez vrowse vyberie os 4.0 a jailbreak ide v pohode.

celý text





Čtěte více